<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<meta charset="UTF-8" />
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://globeafrique.com/xmlrpc.php" />
	<script>var et_site_url='https://globeafrique.com';var et_post_id='19350';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Liberia Business and Investment Forum 2021 | Globe Afrique - Africa and World News</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//translate.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Globe Afrique - Africa and World News &raquo; Feed" href="https://globeafrique.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Globe Afrique - Africa and World News &raquo; Comments Feed" href="https://globeafrique.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Globe Afrique - Africa and World News &raquo; Liberia Business and Investment Forum 2021 Comments Feed" href="https://globeafrique.com/liberia-business-and-investment-forum-2021/feed/" />

				<meta property="og:title" content="Liberia Business and Investment Forum 2021 - Globe Afrique - Africa and World News" />
				<meta property="og:type" content="article" />
				<meta property="og:description" content="2nd Liberia Business &amp; Investment Forum: &quot;Business Opportunities for Sustainable Economic Growth" />
				<meta property="og:url" content="https://globeafrique.com/liberia-business-and-investment-forum-2021/" />
				<meta property="og:site_name" content="Globe Afrique - Africa and World News" />
			<meta property="og:image" content="https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-780x400.jpg" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/globeafrique.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='formidable-css'  href='https://globeafrique.com/wp-content/plugins/formidable/css/formidableforms.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://globeafrique.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://globeafrique.com/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css'  href='https://globeafrique.com/wp-includes/css/dist/components/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css'  href='https://globeafrique.com/wp-includes/css/dist/block-editor/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css'  href='https://globeafrique.com/wp-includes/css/dist/nux/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css'  href='https://globeafrique.com/wp-includes/css/dist/editor/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='captain-form-block-style-css-css'  href='https://globeafrique.com/wp-content/plugins/captainform/admin/gutenberg/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-language-translator-css'  href='https://globeafrique.com/wp-content/plugins/google-language-translator/css/style.css' type='text/css' media='' />
<link rel='stylesheet' id='glt-toolbar-styles-css'  href='https://globeafrique.com/wp-content/plugins/google-language-translator/css/toolbar.css' type='text/css' media='' />
<link rel='stylesheet' id='taqyeem-buttons-style-css'  href='https://globeafrique.com/wp-content/plugins/taqyeem-buttons/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='forms-for-campaign-monitor-custom_cm_monitor_css-css'  href='https://globeafrique.com/wp-content/plugins/forms-for-campaign-monitor/forms/views/public/css/app.css' type='text/css' media='all' />
<link rel='stylesheet' id='et_monarch-css-css'  href='https://globeafrique.com/wp-content/plugins/monarch/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='et-gf-open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-modules-style-css'  href='https://globeafrique.com/wp-content/plugins/divi-builder/includes/builder/styles/frontend-builder-plugin-style.unified.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://globeafrique.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-styles-css'  href='https://globeafrique.com/wp-content/themes/jannah/assets/css/taqyeem.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-css-styles-css'  href='https://globeafrique.com/wp-content/themes/jannah/assets/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-css-ilightbox-css'  href='https://globeafrique.com/wp-content/themes/jannah/assets/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<style id='tie-css-ilightbox-inline-css' type='text/css'>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</style>
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var tie = {"is_rtl":"","ajaxurl":"https:\/\/globeafrique.com\/wp-admin\/admin-ajax.php","mobile_menu_active":"true","mobile_menu_top":"","mobile_menu_parent":"","lightbox_all":"true","lightbox_gallery":"true","lightbox_skin":"dark","lightbox_thumb":"horizontal","lightbox_arrows":"true","is_singular":"1","is_sticky_video":"1","reading_indicator":"true","lazyload":"","select_share":"true","select_share_twitter":"true","select_share_facebook":"true","select_share_linkedin":"true","select_share_email":"","facebook_app_id":"","twitter_username":"","responsive_tables":"true","ad_blocker_detector":"","sticky_behavior":"upwards","sticky_desktop":"true","sticky_mobile":"true","sticky_mobile_behavior":"default","ajax_loader":"<div class=\"loader-overlay\"><div class=\"spinner-circle\"><\/div><\/div>","type_to_search":"1","lang_no_results":"Nothing Found"};
/* ]]> */
</script>
<script   type='text/javascript' src='https://globeafrique.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://globeafrique.com/wp-json/" /><link rel="alternate" type="application/json" href="https://globeafrique.com/wp-json/wp/v2/posts/19350" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://globeafrique.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://globeafrique.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://globeafrique.com/?p=19350' />
<link rel="alternate" type="application/json+oembed" href="https://globeafrique.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://globeafrique.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;format=xml" />
<style type="text/css">#google_language_translator { width:auto !important; }.goog-tooltip {display: none !important;}.goog-tooltip:hover {display: none !important;}.goog-text-highlight {background-color: transparent !important; border: none !important; box-shadow: none !important;}#flags { display:none; }#google_language_translator {color: transparent;}body { top:0px !important; }</style><meta name="generator" content="Site Kit by Google 1.30.0" /><!-- SEO meta tags powered by SmartCrawl -->
<link rel="canonical" href="https://globeafrique.com/liberia-business-and-investment-forum-2021/" />
<meta name="description" content="2nd Liberia Business &amp; Investment Forum: &quot;Business Opportunities for Sustainable Economic Growth&quot; The Embassy of the Republic of Liberia in Washington, D.C, in collaboration with the Consulate General in New York, Consulates in Minnesota, Georgia, and the National Investment Commis ..." />
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"Organization","@id":"https:\/\/globeafrique.com\/#schema-publishing-organization","url":"https:\/\/globeafrique.com","name":"Globe Afrique - Africa and World News"},{"@type":"WebSite","@id":"https:\/\/globeafrique.com\/#schema-website","url":"https:\/\/globeafrique.com","name":"Globe Afrique - Africa and World News","encoding":"UTF-8","potentialAction":{"@type":"SearchAction","target":"https:\/\/globeafrique.com\/search\/{search_term_string}\/","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/#schema-webpage","isPartOf":{"@id":"https:\/\/globeafrique.com\/#schema-website"},"publisher":{"@id":"https:\/\/globeafrique.com\/#schema-publishing-organization"},"url":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/"},{"@type":"Article","mainEntityOfPage":{"@id":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/#schema-webpage"},"author":{"@type":"Person","@id":"https:\/\/globeafrique.com\/author\/globe-afrique-news-desk\/#schema-author","name":"Globe Afrique News Desk","url":"https:\/\/globeafrique.com\/author\/globe-afrique-news-desk\/","description":"Globe Afrique\u2019s News Desk coordinates and analyses news stories from around the world as well as the gathering or distribution of news.\r\nGlobe Afrique, a US-based institution, is Africa\u2019s leading investigative media entity.  The institution\u2019s researchers, analysts, reporters, and contributors deeply investigate and report on a single topic of interest, such as serious crimes, political corruption, or corporate wrongdoing. The institution, which sometimes spends weeks or months researching and preparing investigative reports, also researches into social and legal issues.  Have a news tip, write to globeafriquellc@gmail.com"},"publisher":{"@id":"https:\/\/globeafrique.com\/#schema-publishing-organization"},"dateModified":"2021-06-02T09:53:56","datePublished":"2021-06-02T09:49:43","headline":"Liberia Business and Investment Forum 2021 | Globe Afrique - Africa and World News","description":"2nd Liberia Business &amp; Investment Forum: &quot;Business Opportunities for Sustainable Economic Growth&quot; The Embassy of the Republic of Liberia in Washington, D.C, in collaboration with the Consulate General in New York, Consulates in Minnesota, Georgia, and the National Investment Commis ...","name":"Liberia Business and Investment Forum 2021","image":{"@type":"ImageObject","@id":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/#schema-article-image","url":"https:\/\/globeafrique.com\/wp-content\/uploads\/2021\/06\/Liberia-Business-Forum-2021.jpg","height":400,"width":800},"thumbnailUrl":"https:\/\/globeafrique.com\/wp-content\/uploads\/2021\/06\/Liberia-Business-Forum-2021.jpg"}]}</script>
<!-- /SEO -->
<script type='text/javascript'>
/* <![CDATA[ */
var taqyeem = {"ajaxurl":"https://globeafrique.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};
/* ]]> */
</script>

<style type="text/css" id="et-bloom-custom-css">
					.et_bloom .et_bloom_optin_1 .et_bloom_form_content { background-color: #c9c6b9 !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_container .et_bloom_form_header { background-color: #404b5c !important; } .et_bloom .et_bloom_optin_1 .carrot_edge .et_bloom_form_content:before { border-top-color: #404b5c !important; } .et_bloom .et_bloom_optin_1 .carrot_edge.et_bloom_form_right .et_bloom_form_content:before, .et_bloom .et_bloom_optin_1 .carrot_edge.et_bloom_form_left .et_bloom_form_content:before { border-top-color: transparent !important; border-left-color: #404b5c !important; }
						@media only screen and ( max-width: 767px ) {.et_bloom .et_bloom_optin_1 .carrot_edge.et_bloom_form_right .et_bloom_form_content:before { border-top-color: #404b5c !important; border-left-color: transparent !important; }.et_bloom .et_bloom_optin_1 .carrot_edge.et_bloom_form_left .et_bloom_form_content:after { border-bottom-color: #404b5c !important; border-left-color: transparent !important; }
						}.et_bloom .et_bloom_optin_1 .et_bloom_form_content button { background-color: #7d7a73 !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content .et_bloom_fields i { color: #7d7a73 !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content .et_bloom_custom_field_radio i:before { background: #7d7a73 !important; } .et_bloom .et_bloom_optin_1.et_bloom_optin .et_bloom_border_inset { -moz-box-shadow: inset 0 0 0 3px #d3cec5; -webkit-box-shadow: inset 0 0 0 3px #d3cec5; box-shadow: inset 0 0 0 3px #d3cec5; border-color: #404b5c; } .et_bloom .et_bloom_optin_1.et_bloom_optin .et_bloom_border_inset.et_bloom_border_position_top { -moz-box-shadow: inset 0 3px 0 0 #d3cec5; -webkit-box-shadow: inset 0 3px 0 0 #d3cec5; box-shadow: inset 0 3px 0 0 #d3cec5; border-color: #404b5c; } .et_bloom .et_bloom_optin_1 .et_bloom_form_content button { background-color: #7d7a73 !important; } .et_bloom .et_bloom_optin_1 .et_bloom_form_container h2, .et_bloom .et_bloom_optin_1 .et_bloom_form_container h2 span, .et_bloom .et_bloom_optin_1 .et_bloom_form_container h2 strong { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; }.et_bloom .et_bloom_optin_1 .et_bloom_form_container p, .et_bloom .et_bloom_optin_1 .et_bloom_form_container p span, .et_bloom .et_bloom_optin_1 .et_bloom_form_container p strong, .et_bloom .et_bloom_optin_1 .et_bloom_form_container form input, .et_bloom .et_bloom_optin_1 .et_bloom_form_container form button span { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; } 
				</style><link rel="preload" href="https://globeafrique.com/wp-content/plugins/divi-builder/core/admin/fonts/modules.ttf" as="font" crossorigin="anonymous"><style type="text/css" id="et-social-custom-css">
				 
			</style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3289390361538516",
    enable_page_level_ads: true
  });
</script>
<meta name="generator" content="Jannah 3.2.0" />
<meta name="theme-color" content="#795548" /><meta name="viewport" content="width=device-width, initial-scale=1.0" />
<!-- BEGIN recaptcha, injected by plugin wp-recaptcha-integration  -->

<!-- END recaptcha -->

					<script>
						WebFontConfig ={
							google:{
								families: ['Brawler::latin', 'Lora:regular,500,600,700:latin', 'PT+Sans:100,100italic,300,300italic,regular,italic,500,500italic,700,700italic,800,800italic,900,900italic:latin']
							}
						};
						(function(){
							var wf   = document.createElement('script');
							wf.src   = '//ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
							wf.type  = 'text/javascript';
							wf.async = 'true';
							var s = document.getElementsByTagName('script')[0];
							s.parentNode.insertBefore(wf, s);
						})();
					</script>
				<link rel="icon" href="https://globeafrique.com/wp-content/uploads/2016/11/cropped-GA-Icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://globeafrique.com/wp-content/uploads/2016/11/cropped-GA-Icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://globeafrique.com/wp-content/uploads/2016/11/cropped-GA-Icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://globeafrique.com/wp-content/uploads/2016/11/cropped-GA-Icon-270x270.png" />
</head>

<body id="tie-body" class="post-template-default single single-post postid-19350 single-format-standard et_divi_builder et_bloom et_monarch wrapper-has-shadow block-head-1 magazine2 is-thumb-overlay-disabled is-desktop is-header-layout-2 sidebar-right has-sidebar post-layout-1 narrow-title-narrow-media is-standard-format has-mobile-share post-has-toggle hide_share_post_top hide_share_post_bottom et-pb-theme-jannah et-db et_minified_js et_minified_css">


<div class="background-overlay">

	<div id="tie-container" class="site tie-container">

		
		<div id="tie-wrapper">

			<div class="stream-item stream-item-above-header"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-9274722532808821",
    enable_page_level_ads: true
  });
</script></div>
<header id="theme-header" class="theme-header header-layout-2 main-nav-light main-nav-below top-nav-active top-nav-dark top-nav-above mobile-header-default">
	
<nav id="top-nav" data-skin="search-in-top-nav live-search-dark" class="has-menu-components top-nav header-nav live-search-parent" aria-label="Secondary Navigation">
	<div class="container">
		<div class="topbar-wrapper">

			
			<div class="tie-alignleft">
				<div class="top-menu header-menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-17934" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-17934"><a href="https://globeafrique.com/">LIBERIA</a></li>
<li id="menu-item-14492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14492"><a href="https://globeafrique.com/category/blog/">WORLD</a>
<ul class="sub-menu">
	<li id="menu-item-14490" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14490"><a href="https://globeafrique.com/category/news/">NEWS</a></li>
</ul>
</li>
<li id="menu-item-14493" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14493"><a href="https://globeafrique.com/category/governance/">POLITICS</a>
<ul class="sub-menu">
	<li id="menu-item-14499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14499"><a href="https://globeafrique.com/category/corruption/">CORRUPTION</a></li>
	<li id="menu-item-17903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17903"><a href="https://globeafrique.com/category/governance/">Governance</a></li>
</ul>
</li>
<li id="menu-item-14491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14491"><a href="https://globeafrique.com/category/opinion/">OPINION</a>
<ul class="sub-menu">
	<li id="menu-item-17914" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17914"><a href="https://globeafrique.com/category/letters/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-14497" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-14497 tie-current-menu"><a href="https://globeafrique.com/category/business/">BUSINESS</a>
<ul class="sub-menu">
	<li id="menu-item-17904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17904"><a href="https://globeafrique.com/category/energy-environment/">Energy &#038; Environment</a></li>
</ul>
</li>
<li id="menu-item-14500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14500"><a href="https://globeafrique.com/category/justice/">JUSTICE</a>
<ul class="sub-menu">
	<li id="menu-item-17912" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17912"><a href="https://globeafrique.com/category/in-the-news/">In the News</a></li>
	<li id="menu-item-17911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17911"><a href="https://globeafrique.com/category/human-rights/">Human Rights</a></li>
</ul>
</li>
<li id="menu-item-14495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14495"><a href="https://globeafrique.com/category/entertainment/">ENTERTAINMENT</a>
<ul class="sub-menu">
	<li id="menu-item-17909" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17909"><a href="https://globeafrique.com/category/sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-17905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17905"><a href="#">LIVING</a>
<ul class="sub-menu">
	<li id="menu-item-17906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17906"><a href="https://globeafrique.com/category/events/">Events</a></li>
	<li id="menu-item-17907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17907"><a href="https://globeafrique.com/category/fashion/">Fashion</a></li>
	<li id="menu-item-17908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17908"><a href="https://globeafrique.com/category/food/">Food</a></li>
	<li id="menu-item-17910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17910"><a href="https://globeafrique.com/category/health/">Health</a></li>
	<li id="menu-item-17915" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17915"><a href="https://globeafrique.com/category/lifestyle/">Lifestyle</a></li>
</ul>
</li>
</ul></div>			</div><!-- .tie-alignleft /-->

			<div class="tie-alignright">
				<ul class="components">		<li class="search-bar menu-item custom-menu-link" aria-label="Search">
			<form method="get" id="search" action="https://globeafrique.com//">
				<input id="search-input" class="is-ajax-search" type="text" name="s" title="Search for" placeholder="Search for" />
				<button id="search-submit" type="submit"><span class="fa fa-search" aria-hidden="true"></span></button>
			</form>
		</li>
			<li class="side-aside-nav-icon menu-item custom-menu-link">
		<a href="#">
			<span class="fa fa-navicon" aria-hidden="true"></span>
			<span class="screen-reader-text">Sidebar</span>
		</a>
	</li>
		<li class="popup-login-icon menu-item custom-menu-link">
	 	<a href="#" class="lgoin-btn tie-popup-trigger">
			<span class="fa fa-lock" aria-hidden="true"></span>
			<span class="screen-reader-text">Log In</span>
		</a>
	</li>
		<li class="random-post-icon menu-item custom-menu-link">
		<a href="/liberia-business-and-investment-forum-2021/?random-post=1" class="random-post" title="Random Article" rel="nofollow">
			<span class="fa fa-random" aria-hidden="true"></span>
			<span class="screen-reader-text">Random Article</span>
		</a>
	</li>
			<li class="list-social-icons menu-item custom-menu-link">
			<a href="#" class="follow-btn">
				<span class="fa fa-plus" aria-hidden="true"></span>
				<span class="follow-text">Follow</span>
			</a>
			<ul class="dropdown-social-icons comp-sub-menu"><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-facebook"></span><span class="social-text">Facebook</span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-twitter"></span><span class="social-text">Twitter</span></a></li><li class="social-icons-item"><a class="social-link  youtube-social-icon" title="YouTube" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-youtube"></span><span class="social-text">YouTube</span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-instagram"></span><span class="social-text">Instagram</span></a></li></ul><!-- #dropdown-social-icons /-->		</li><!-- #list-social-icons /-->
		</ul><!-- Components -->			</div><!-- .tie-alignright /-->

		</div><!-- .topbar-wrapper /-->
	</div><!-- .container /-->
</nav><!-- #top-nav /-->

<div class="container">
	<div class="tie-row logo-row">

		
		<div class="logo-wrapper">
			<div class="tie-col-md-4 logo-container">
				
		<a href="#" id="mobile-menu-icon">
			<span class="nav-icon"></span>

				<span class="screen-reader-text">Menu</span>		</a>
		
		<div id="logo" class="text-logo" style="margin-top: 50px; margin-bottom: 50px;">

			
			<a title="Globe Afrique" href="https://globeafrique.com/">
				<div class="logo-text">Globe Afrique</div>			</a>

			
		</div><!-- #logo /-->

					</div><!-- .tie-col /-->
		</div><!-- .logo-wrapper /-->

		
	</div><!-- .tie-row /-->
</div><!-- .container /-->

<div class="main-nav-wrapper">
	<nav id="main-nav" data-skin="search-in-main-nav live-search-light" class="main-nav header-nav live-search-parent"  aria-label="Primary Navigation">
		<div class="container">

			<div class="main-menu-wrapper">

				
				<div id="menu-components-wrap">

					
					<div class="main-menu main-menu-wrap tie-alignleft">
						<div id="main-nav-menu" class="main-menu header-menu"><ul id="menu-main-menu-1" class="menu" role="menubar"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-17934"><a href="https://globeafrique.com/">LIBERIA</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14492" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://globeafrique.com/category/blog/">WORLD</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14490"><a href="https://globeafrique.com/category/news/">NEWS</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14493" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://globeafrique.com/category/governance/">POLITICS</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14499"><a href="https://globeafrique.com/category/corruption/">CORRUPTION</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17903"><a href="https://globeafrique.com/category/governance/">Governance</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14491" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://globeafrique.com/category/opinion/">OPINION</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17914"><a href="https://globeafrique.com/category/letters/">Letters to the Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-14497 tie-current-menu" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://globeafrique.com/category/business/">BUSINESS</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17904"><a href="https://globeafrique.com/category/energy-environment/">Energy &#038; Environment</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14500" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://globeafrique.com/category/justice/">JUSTICE</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17912"><a href="https://globeafrique.com/category/in-the-news/">In the News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17911"><a href="https://globeafrique.com/category/human-rights/">Human Rights</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14495" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://globeafrique.com/category/entertainment/">ENTERTAINMENT</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17909"><a href="https://globeafrique.com/category/sports/">Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17905" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="#">LIVING</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17906"><a href="https://globeafrique.com/category/events/">Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17907"><a href="https://globeafrique.com/category/fashion/">Fashion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17908"><a href="https://globeafrique.com/category/food/">Food</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17910"><a href="https://globeafrique.com/category/health/">Health</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17915"><a href="https://globeafrique.com/category/lifestyle/">Lifestyle</a></li>
</ul>
</li>
</ul></div>					</div><!-- .main-menu.tie-alignleft /-->

					<ul class="components">		<li class="search-bar menu-item custom-menu-link" aria-label="Search">
			<form method="get" id="search" action="https://globeafrique.com//">
				<input id="search-input" class="is-ajax-search" type="text" name="s" title="Search for" placeholder="Search for" />
				<button id="search-submit" type="submit"><span class="fa fa-search" aria-hidden="true"></span></button>
			</form>
		</li>
			<li class="side-aside-nav-icon menu-item custom-menu-link">
		<a href="#">
			<span class="fa fa-navicon" aria-hidden="true"></span>
			<span class="screen-reader-text">Sidebar</span>
		</a>
	</li>
		<li class="random-post-icon menu-item custom-menu-link">
		<a href="/liberia-business-and-investment-forum-2021/?random-post=1" class="random-post" title="Random Article" rel="nofollow">
			<span class="fa fa-random" aria-hidden="true"></span>
			<span class="screen-reader-text">Random Article</span>
		</a>
	</li>
	</ul><!-- Components -->
				</div><!-- #menu-components-wrap /-->
			</div><!-- .main-menu-wrapper /-->
		</div><!-- .container /-->
	</nav><!-- #main-nav /-->
</div><!-- .main-nav-wrapper /-->

</header>


			<div id="content" class="site-content container">
				<div class="tie-row main-content-row">
		

<div class="main-content tie-col-md-8 tie-col-xs-12" role="main">

	
	<article id="the-post" class="container-wrapper post-content tie-standard">

		
<header class="entry-header-outer">

	<nav id="breadcrumb"><a href="https://globeafrique.com/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><em class="delimiter">/</em><a href="https://globeafrique.com/category/business/">Business</a><em class="delimiter">/</em><span class="current">Liberia Business and Investment Forum 2021</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/globeafrique.com\/"}},{"@type":"ListItem","position":2,"item":{"name":"Business","@id":"https:\/\/globeafrique.com\/category\/business\/"}}]}</script>
	<div class="entry-header">

		<span class="post-cat-wrap"><a class="post-cat tie-cat-7" href="https://globeafrique.com/category/business/">Business</a><a class="post-cat tie-cat-2" href="https://globeafrique.com/category/news/">News</a><a class="post-cat tie-cat-2100" href="https://globeafrique.com/category/news-liberia/">News-Liberia</a></span>
		<h1 class="post-title entry-title">Liberia Business and Investment Forum 2021</h1>

		<div class="post-meta">
					<span class="meta-author-avatar">
						<a href="https://globeafrique.com/author/globe-afrique-news-desk/"><img alt='' src='https://secure.gravatar.com/avatar/b18b426f9c61320d041b63a79240ed06?s=140&#038;r=g' srcset='https://secure.gravatar.com/avatar/b18b426f9c61320d041b63a79240ed06?s=280&#038;r=g 2x' class='avatar avatar-140 photo' height='140' width='140' loading='lazy'/>
						</a>
					</span>
				
				<span class="meta-author meta-item"><a href="https://globeafrique.com/author/globe-afrique-news-desk/" class="author-name" title="Globe Afrique News Desk">Globe Afrique News Desk</a>
				</span>
			
					<a href="mailto:courmerssie@aol.com" class="author-email-link" target="_blank" rel="nofollow noopener">
						<span class="fa fa-envelope" aria-hidden="true"></span>
						<span class="screen-reader-text"></span>
					</a>
				<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span><div class="tie-alignright"><span class="meta-comment meta-item"><a href="https://globeafrique.com/liberia-business-and-investment-forum-2021/#respond"><span class="fa fa-comments" aria-hidden="true"></span> 0</a></span><span class="meta-views meta-item warm"><span class="tie-icon-fire" aria-hidden="true"></span> 58 </span><span class="meta-reading-time meta-item"><span class="fa fa-bookmark" aria-hidden="true"></span> 1 minute read</span> </div><div class="clearfix"></div></div><!-- .post-meta -->	</div><!-- .entry-header /-->

	
	
</header><!-- .entry-header-outer /-->


		<div class="post-footer post-footer-on-top">
			<div class="share-links  share-centered icons-only">
				<a href="https://www.facebook.com/sharer.php?u=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="facebook-share-btn"><span class="fa fa-facebook"></span> <span class="screen-reader-text">Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Liberia+Business+and+Investment+Forum+2021&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="twitter-share-btn"><span class="fa fa-twitter"></span> <span class="screen-reader-text">Twitter</span></a><a href="https://plusone.google.com/_/+1/confirm?hl=en&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;name=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="google-share-btn"><span class="fa fa-google"></span> <span class="screen-reader-text">Google+</span></a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;title=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="linkedin-share-btn"><span class="fa fa-linkedin"></span> <span class="screen-reader-text">LinkedIn</span></a><a href="https://www.stumbleupon.com/submit?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;title=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="stumbleupon-share-btn"><span class="fa fa-stumbleupon"></span> <span class="screen-reader-text">StumbleUpon</span></a><a href="https://www.tumblr.com/share/link?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;name=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="tumblr-share-btn"><span class="fa fa-tumblr"></span> <span class="screen-reader-text">Tumblr</span></a><a href="https://pinterest.com/pin/create/button/?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;description=Liberia+Business+and+Investment+Forum+2021&#038;media=https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-780x400.jpg" rel="external noopener" target="_blank" class="pinterest-share-btn"><span class="fa fa-pinterest"></span> <span class="screen-reader-text">Pinterest</span></a><a href="https://reddit.com/submit?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;title=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="reddit-share-btn"><span class="fa fa-reddit"></span> <span class="screen-reader-text">Reddit</span></a><a href="https://vk.com/share.php?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="vk-share-btn"><span class="fa fa-vk"></span> <span class="screen-reader-text">VKontakte</span></a><a href="https://connect.ok.ru/dk?st.cmd=WidgetSharePreview&#038;st.shareUrl=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;description=Liberia+Business+and+Investment+Forum+2021&#038;media=https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-780x400.jpg" rel="external noopener" target="_blank" class="odnoklassniki-share-btn"><span class="fa fa-odnoklassniki"></span> <span class="screen-reader-text">Odnoklassniki</span></a><a href="https://getpocket.com/save?title=Liberia+Business+and+Investment+Forum+2021&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="pocket-share-btn"><span class="fa fa-get-pocket"></span> <span class="screen-reader-text">Pocket</span></a>			</div><!-- .share-links /-->
		</div><!-- .post-footer-on-top /-->

		<div  class="featured-area"><div class="featured-area-inner"><figure class="single-featured-image"><img width="780" height="400" src="https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-780x400.jpg" class="attachment-jannah-image-post size-jannah-image-post wp-post-image" alt="" loading="lazy" /></figure></div></div>
		<div class="entry-content entry clearfix">

			
			
<h2><strong>2nd Liberia Business &amp; Investment Forum: &#8220;Business Opportunities for Sustainable Economic Growth&#8221;</strong></h2>



<p>The Embassy of the Republic of Liberia in Washington, D.C, in collaboration with the Consulate General in New York, Consulates in Minnesota, Georgia, and the National Investment Commission of Liberia, officially announce the holding of the 2nd Liberia Business &amp; Investment Forum under the theme: &#8220;Business Opportunities for Sustainable Economic Growth,&#8221; scheduled for Wednesday, June 30, 2021, from 8:00 am &#8211; 3:25 pm. <strong>This event will be held virtually</strong>.</p>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://globeafrique.com/wp-content/uploads/2021/06/George-Patten-1024x683.jpg" alt="" class="wp-image-19351" srcset="https://globeafrique.com/wp-content/uploads/2021/06/George-Patten-1024x683.jpg 1024w, https://globeafrique.com/wp-content/uploads/2021/06/George-Patten-300x200.jpg 300w, https://globeafrique.com/wp-content/uploads/2021/06/George-Patten-768x512.jpg 768w, https://globeafrique.com/wp-content/uploads/2021/06/George-Patten-1080x720.jpg 1080w, https://globeafrique.com/wp-content/uploads/2021/06/George-Patten-610x407.jpg 610w, https://globeafrique.com/wp-content/uploads/2021/06/George-Patten.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Ambassador George S.W. Patten, Sr.</figcaption></figure>



<p>The Forum will focus on the following sectors: Health, Agriculture, and Tourism, and will provide a platform and opportunity for the private sector, investors, and Government representatives to engage in these sectors for investment. </p>



<p>The Forum&#8217;s goal is to encourage U.S. private sector investment in Liberia and increase trade and commerce between Liberia and the United States to support the Liberian Government&#8217;s Pro-Poor Agenda for Prosperity and Development (PAPD). The Structure of the Forum will include an Opening Ceremony, Presentations, Panel Discussions, and Networking lounges/sections on Business to Business (B2B), Business to Government (B2G), and Government to Government (G2G) and a Virtual Deal Room.</p>



<p>Several high-ranking government officials from Liberia and the United States will be in attendance to provide relevant information on the priority sectors for investment. Speakers from Liberia will include Hon. Dee-Maxwell Saah Kemeyah, Sr., Minister of Foreign Affairs; Hon. Samuel D. Tweah, Minister of Finance &amp; Development Planning; Hon. Mawine Diggs, Minister of Commerce; Hon. Jeanine Milly Cooper, Minister of Agriculture; Hon. Wilhemina Jallah, Minister of Health, Hon. Ledgerhood Rennie, Minister of Information, Culture and Tourism; Hon. Molewuleh B. Gray, Esq. Chairman, National Investment Commission and the Liberia Chamber of Commerce, among others.</p>



<p>The private sector in Liberia and the Liberia Business Association in the Americas will also be represented at the Forum. Other invited guests are Senior U.S. Government Officials, including the Departments of Agriculture, Commerce, the United States Chamber of Commerce, among others. The United States Agency for International Development (USAID), and Prosper Africa, are providing support to the business forum.</p>



<p>In this regard, we are pleased to extend an official invitation to you as a participant at the Forum.</p>



<p>Register here: <a href="https://www.eventbrite.com/e/2nd-liberia-business-investment-forum-tickets-153564488519" target="_blank" rel="noreferrer noopener">2nd Liberia Business &amp; Investment Forum Tickets, Wed, Jun 30, 2021 at 8:00 AM | Eventbrite</a></p>



<p></p>
<span class="et_bloom_bottom_trigger"></span><span class="et_social_bottom_trigger"></span>
			
		</div><!-- .entry-content /-->

		<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","dateCreated":"2021-06-02T09:49:43+00:00","datePublished":"2021-06-02T09:49:43+00:00","dateModified":"2021-06-02T09:53:56+00:00","headline":"Liberia Business and Investment Forum 2021","name":"Liberia Business and Investment Forum 2021","keywords":[],"url":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/","description":"2nd Liberia Business &amp; Investment Forum: \"Business Opportunities for Sustainable Economic Growth\" The Embassy of the Republic of Liberia in Washington, D.C, in collaboration with the Consulate Gen","copyrightYear":"2021","articleSection":"Business,News,News-Liberia","articleBody":"\n2nd Liberia Business &amp; Investment Forum: \"Business Opportunities for Sustainable Economic Growth\"\n\n\n\nThe Embassy of the Republic of Liberia in Washington, D.C, in collaboration with the Consulate General in New York, Consulates in Minnesota, Georgia, and the National Investment Commission of Liberia, officially announce the holding of the 2nd Liberia Business &amp; Investment Forum under the theme: \"Business Opportunities for Sustainable Economic Growth,\" scheduled for Wednesday, June 30, 2021, from 8:00 am - 3:25 pm. This event will be held virtually.\n\n\n\nAmbassador George S.W. Patten, Sr.\n\n\n\nThe Forum will focus on the following sectors: Health, Agriculture, and Tourism, and will provide a platform and opportunity for the private sector, investors, and Government representatives to engage in these sectors for investment. \n\n\n\nThe Forum's goal is to encourage U.S. private sector investment in Liberia and increase trade and commerce between Liberia and the United States to support the Liberian Government's Pro-Poor Agenda for Prosperity and Development (PAPD). The Structure of the Forum will include an Opening Ceremony, Presentations, Panel Discussions, and Networking lounges\/sections on Business to Business (B2B), Business to Government (B2G), and Government to Government (G2G) and a Virtual Deal Room.\n\n\n\nSeveral high-ranking government officials from Liberia and the United States will be in attendance to provide relevant information on the priority sectors for investment. Speakers from Liberia will include Hon. Dee-Maxwell Saah Kemeyah, Sr., Minister of Foreign Affairs; Hon. Samuel D. Tweah, Minister of Finance &amp; Development Planning; Hon. Mawine Diggs, Minister of Commerce; Hon. Jeanine Milly Cooper, Minister of Agriculture; Hon. Wilhemina Jallah, Minister of Health, Hon. Ledgerhood Rennie, Minister of Information, Culture and Tourism; Hon. Molewuleh B. Gray, Esq. Chairman, National Investment Commission and the Liberia Chamber of Commerce, among others.\n\n\n\nThe private sector in Liberia and the Liberia Business Association in the Americas will also be represented at the Forum. Other invited guests are Senior U.S. Government Officials, including the Departments of Agriculture, Commerce, the United States Chamber of Commerce, among others. The United States Agency for International Development (USAID), and Prosper Africa, are providing support to the business forum.\n\n\n\nIn this regard, we are pleased to extend an official invitation to you as a participant at the Forum.\n\n\n\nRegister here: 2nd Liberia Business &amp; Investment Forum Tickets, Wed, Jun 30, 2021 at 8:00 AM | Eventbrite\n\n\n\n\n","publisher":{"@id":"#Publisher","@type":"Organization","name":"Globe Afrique - Africa and World News","logo":{"@type":"ImageObject","url":"https:\/\/globeafrique.com\/wp-content\/uploads\/2018\/11\/logo.png"},"sameAs":["#","#","#","#"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/","breadcrumb":{"@id":"#Breadcrumb"}},"author":{"@type":"Person","name":"Globe Afrique News Desk","url":"https:\/\/globeafrique.com\/author\/globe-afrique-news-desk\/"},"image":{"@type":"ImageObject","url":"https:\/\/globeafrique.com\/wp-content\/uploads\/2021\/06\/Liberia-Business-Forum-2021.jpg","width":800,"height":400}}</script>
		<div class="toggle-post-content clearfix">
			<a id="toggle-post-button" class="button" href="#">
				Show More <span class="fa fa-chevron-down"></span>
			</a>
		</div><!-- .toggle-post-content -->
		
		<div class="post-footer post-footer-on-bottom">
			<div class="share-links  share-centered icons-only">
										<div class="share-title">
						<span class="fa fa-share-alt" aria-hidden="true"></span>
						<span> Share</span>
						</div>
						<a href="https://www.facebook.com/sharer.php?u=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="facebook-share-btn"><span class="fa fa-facebook"></span> <span class="screen-reader-text">Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Liberia+Business+and+Investment+Forum+2021&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="twitter-share-btn"><span class="fa fa-twitter"></span> <span class="screen-reader-text">Twitter</span></a><a href="https://plusone.google.com/_/+1/confirm?hl=en&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;name=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="google-share-btn"><span class="fa fa-google"></span> <span class="screen-reader-text">Google+</span></a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;title=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="linkedin-share-btn"><span class="fa fa-linkedin"></span> <span class="screen-reader-text">LinkedIn</span></a><a href="https://www.stumbleupon.com/submit?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;title=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="stumbleupon-share-btn"><span class="fa fa-stumbleupon"></span> <span class="screen-reader-text">StumbleUpon</span></a><a href="https://www.tumblr.com/share/link?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;name=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="tumblr-share-btn"><span class="fa fa-tumblr"></span> <span class="screen-reader-text">Tumblr</span></a><a href="https://pinterest.com/pin/create/button/?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;description=Liberia+Business+and+Investment+Forum+2021&#038;media=https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-780x400.jpg" rel="external noopener" target="_blank" class="pinterest-share-btn"><span class="fa fa-pinterest"></span> <span class="screen-reader-text">Pinterest</span></a><a href="https://reddit.com/submit?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;title=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="reddit-share-btn"><span class="fa fa-reddit"></span> <span class="screen-reader-text">Reddit</span></a><a href="https://vk.com/share.php?url=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="vk-share-btn"><span class="fa fa-vk"></span> <span class="screen-reader-text">VKontakte</span></a><a href="https://connect.ok.ru/dk?st.cmd=WidgetSharePreview&#038;st.shareUrl=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;description=Liberia+Business+and+Investment+Forum+2021&#038;media=https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-780x400.jpg" rel="external noopener" target="_blank" class="odnoklassniki-share-btn"><span class="fa fa-odnoklassniki"></span> <span class="screen-reader-text">Odnoklassniki</span></a><a href="https://getpocket.com/save?title=Liberia+Business+and+Investment+Forum+2021&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="pocket-share-btn"><span class="fa fa-get-pocket"></span> <span class="screen-reader-text">Pocket</span></a><a href="mailto:?subject=Liberia+Business+and+Investment+Forum+2021&#038;body=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="email-share-btn"><span class="fa fa-envelope"></span> <span class="screen-reader-text">Share via Email</span></a><a href="#" rel="external noopener" target="_blank" class="print-share-btn"><span class="fa fa-print"></span> <span class="screen-reader-text">Print</span></a>			</div><!-- .share-links /-->
		</div><!-- .post-footer-on-top /-->

		
	</article><!-- #the-post /-->

	
	<div class="post-components">

		
	<div id="read-next-block" class="container-wrapper read-next-slider-50">
		<h2 class="read-next-block-title">Read Next</h2>
		
			<section id="tie-read-next" class="slider-area mag-box">

				
					<div id="tie-main-slider-50-read-next" class="tie-main-slider main-slider wide-slider-with-navfor-wrapper wide-slider-wrapper slider-vertical-navigation tie-slick-slider-wrapper" data-slider-id="50"  data-autoplay="true" data-speed="3000">

						
						<div class="main-slider-inner">

							
								<div class="container slider-main-container">
									<div class="tie-slick-slider">
										<ul class="tie-slider-nav"></ul>

										<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup.jpg)" class="slide slide-id-19356 tie-slide-1 tie-standard">
					<a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" class="all-over-thumb-link"><span class="screen-reader-text">Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-2100" href="https://globeafrique.com/category/news-liberia/">News-Liberia</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" title="Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t">Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/Omar-Al-bashir-1170x610.jpg)" class="slide slide-id-19345 tie-slide-2 tie-standard">
					<a href="https://globeafrique.com/icc-hears-testimony-in-landmark-darfur-war-crimes-case/" class="all-over-thumb-link"><span class="screen-reader-text">ICC Hears Testimony in Landmark Darfur War Crimes Case</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-2100" href="https://globeafrique.com/category/news-liberia/">News-Liberia</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/icc-hears-testimony-in-landmark-darfur-war-crimes-case/" title="ICC Hears Testimony in Landmark Darfur War Crimes Case">ICC Hears Testimony in Landmark Darfur War Crimes Case</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/African-Union-Chaos-1000x610.jpg)" class="slide slide-id-19340 tie-slide-3 tie-standard">
					<a href="https://globeafrique.com/fight-breaks-out-at-african-union-parliament/" class="all-over-thumb-link"><span class="screen-reader-text">Fight breaks out at African Union parliament</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-32" href="https://globeafrique.com/category/governance/">Governance</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 1, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/fight-breaks-out-at-african-union-parliament/" title="Fight breaks out at African Union parliament">Fight breaks out at African Union parliament</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/05/Mali-army-supporters.png)" class="slide slide-id-19336 tie-slide-4 tie-standard">
					<a href="https://globeafrique.com/mali-coup-are-military-takeovers-on-the-rise-in-africa/" class="all-over-thumb-link"><span class="screen-reader-text">Mali Coup: Are military takeovers on the rise in Africa?</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-11" href="https://globeafrique.com/category/international_development/">International Development</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 31, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/mali-coup-are-military-takeovers-on-the-rise-in-africa/" title="Mali Coup: Are military takeovers on the rise in Africa?">Mali Coup: Are military takeovers on the rise in Africa?</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/05/Ecowas-suspends-Mali.jpeg)" class="slide slide-id-19330 tie-slide-5 tie-standard">
					<a href="https://globeafrique.com/ecowas-suspends-mali-after-the-second-coup-in-9-months/" class="all-over-thumb-link"><span class="screen-reader-text">ECOWAS suspends Mali after the second coup in 9 months</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-2100" href="https://globeafrique.com/category/news-liberia/">News-Liberia</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 31, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/ecowas-suspends-mali-after-the-second-coup-in-9-months/" title="ECOWAS suspends Mali after the second coup in 9 months">ECOWAS suspends Mali after the second coup in 9 months</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/05/Roman-Protasevich.png)" class="slide slide-id-19317 tie-slide-6 tie-standard">
					<a href="https://globeafrique.com/arresting-journalists-who-criticize-a-government-is-not-a-smart-strategy/" class="all-over-thumb-link"><span class="screen-reader-text">Arresting Journalists Who Criticize a Government is Not a Smart Strategy</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-33" href="https://globeafrique.com/category/human-rights/">Human Rights</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 25, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/arresting-journalists-who-criticize-a-government-is-not-a-smart-strategy/" title="Arresting Journalists Who Criticize a Government is Not a Smart Strategy">Arresting Journalists Who Criticize a Government is Not a Smart Strategy</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/05/APM-Dispute-960x610.jpg)" class="slide slide-id-19313 tie-slide-1 tie-standard">
					<a href="https://globeafrique.com/voices-from-exile-vex-stands-in-firm-solidarity-with-protesting-liberian-workers-at-npa-and-frowns-on-apm-terminals-for-continuous-labor-abuse/" class="all-over-thumb-link"><span class="screen-reader-text">Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-33" href="https://globeafrique.com/category/human-rights/">Human Rights</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 11, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/voices-from-exile-vex-stands-in-firm-solidarity-with-protesting-liberian-workers-at-npa-and-frowns-on-apm-terminals-for-continuous-labor-abuse/" title="Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse">Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/05/Ed-Royce_2-1170x610.jpg)" class="slide slide-id-19309 tie-slide-2 tie-standard">
					<a href="https://globeafrique.com/ed-royce-liberias-new-usd25000-per-month-lobbyist/" class="all-over-thumb-link"><span class="screen-reader-text">Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-2" href="https://globeafrique.com/category/news/">News</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 7, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/ed-royce-liberias-new-usd25000-per-month-lobbyist/" title="Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist">Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/05/Weah.jpg)" class="slide slide-id-19301 tie-slide-3 tie-standard">
					<a href="https://globeafrique.com/episode-1-george-weah-ousmane-bamba-the-europeans-russians-and-how-the-2017-elections-were-rigged/" class="all-over-thumb-link"><span class="screen-reader-text">Episode 1: George Weah, Ousmane Bamba, the Europeans, Russians, and How the 2017 Elections were Rigged</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-26" href="https://globeafrique.com/category/blog/">Blog</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 5, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/episode-1-george-weah-ousmane-bamba-the-europeans-russians-and-how-the-2017-elections-were-rigged/" title="Episode 1: George Weah, Ousmane Bamba, the Europeans, Russians, and How the 2017 Elections were Rigged">Episode 1: George Weah, Ousmane Bamba, the Europeans, Russians, and How the 2017 Elections were Rigged</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/04/USCIS.jpeg)" class="slide slide-id-19287 tie-slide-4 tie-standard">
					<a href="https://globeafrique.com/u-s-attorneys-office-charges-a-nigerian-who-worked-as-a-u-s-immigration-officer-of-illegally-obtaining-u-s-citizenship/" class="all-over-thumb-link"><span class="screen-reader-text">U.S. Attorney’s Office Charges a Nigerian, who worked as a U.S. immigration officer, of Illegally Obtaining U.S. Citizenship</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-2" href="https://globeafrique.com/category/news/">News</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>April 20, 2021</span></span></div>
				<h2 class="thumb-title"><a href="https://globeafrique.com/u-s-attorneys-office-charges-a-nigerian-who-worked-as-a-u-s-immigration-officer-of-illegally-obtaining-u-s-citizenship/" title="U.S. Attorney’s Office Charges a Nigerian, who worked as a U.S. immigration officer, of Illegally Obtaining U.S. Citizenship">U.S. Attorney’s Office Charges a Nigerian, who worked as a U.S. immigration officer, of Illegally Obtaining U.S. Citizenship</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			
									</div><!-- .tie-slick-slider /-->
								</div><!-- .slider-main-container /-->

							
						</div><!-- .main-slider-inner  /-->
					</div><!-- .main-slider /-->

					
						<div class="wide-slider-nav-wrapper vertical-slider-nav ">
							<ul class="tie-slider-nav"></ul>

							<div class="container">
								<div class="tie-row">
									<div class="tie-col-md-12">
										<div class="tie-slick-slider">

											
													<div class="slide tie-slide-5">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span></div>
															<h3 class="thumb-title">Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-6">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span></div>
															<h3 class="thumb-title">ICC Hears Testimony in Landmark Darfur War Crimes Case</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-1">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 1, 2021</span></span></div>
															<h3 class="thumb-title">Fight breaks out at African Union parliament</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-2">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 31, 2021</span></span></div>
															<h3 class="thumb-title">Mali Coup: Are military takeovers on the rise in Africa?</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-3">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 31, 2021</span></span></div>
															<h3 class="thumb-title">ECOWAS suspends Mali after the second coup in 9 months</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-4">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 25, 2021</span></span></div>
															<h3 class="thumb-title">Arresting Journalists Who Criticize a Government is Not a Smart Strategy</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-5">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 11, 2021</span></span></div>
															<h3 class="thumb-title">Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-6">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 7, 2021</span></span></div>
															<h3 class="thumb-title">Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-1">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 5, 2021</span></span></div>
															<h3 class="thumb-title">Episode 1: George Weah, Ousmane Bamba, the Europeans, Russians, and How the 2017 Elections were Rigged</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-2">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>April 20, 2021</span></span></div>
															<h3 class="thumb-title">U.S. Attorney’s Office Charges a Nigerian, who worked as a U.S. immigration officer, of Illegally Obtaining U.S. Citizenship</h3>

														</div>
													</div><!-- slide /-->

													
										</div><!-- .wide_slider_nav /-->
									</div><!-- .tie-col /-->
								</div><!-- .tie-row /-->
							</div><!-- .container /-->
						</div><!-- #wide-slider-nav-wrapper /-->
						
		</section><!-- .slider-area -->

				</div><!-- #read-next-block -->

	
		<div class="about-author container-wrapper">

								<div class="author-avatar">
						<a href="https://globeafrique.com/author/globe-afrique-news-desk/">
							<img alt='' src='https://secure.gravatar.com/avatar/b18b426f9c61320d041b63a79240ed06?s=180&#038;r=g' srcset='https://secure.gravatar.com/avatar/b18b426f9c61320d041b63a79240ed06?s=360&#038;r=g 2x' class='avatar avatar-180 photo' height='180' width='180' loading='lazy'/>						</a>
					</div><!-- .author-avatar /-->
					
			<div class="author-info">
				<h3 class="author-name"><a href="https://globeafrique.com/author/globe-afrique-news-desk/">Globe Afrique News Desk</a></h3>

				<div class="author-bio">
					Globe Afrique’s News Desk coordinates and analyses news stories from around the world as well as the gathering or distribution of news.
Globe Afrique, a US-based institution, is Africa’s leading investigative media entity.  The institution’s researchers, analysts, reporters, and contributors deeply investigate and report on a single topic of interest, such as serious crimes, political corruption, or corporate wrongdoing. The institution, which sometimes spends weeks or months researching and preparing investigative reports, also researches into social and legal issues.  Have a news tip, write to globeafriquellc@gmail.com				</div><!-- .author-bio /-->

				<ul class="social-icons"></ul>			</div><!-- .author-info /-->
			<div class="clearfix"></div>
		</div><!-- .about-author /-->
		<div class="prev-next-post-nav container-wrapper media-overlay">
			<div class="tie-col-xs-6 prev-post">
				<a href="https://globeafrique.com/icc-prosecutor-urges-sudan-to-hand-over-darfur-suspects/" style="background-image: url(https://globeafrique.com/wp-content/uploads/2018/08/ICC.jpeg)" class="post-thumb">
					<div class="post-thumb-overlay-wrap">
						<div class="post-thumb-overlay">
							<span class="icon"></span>
						</div>
					</div>
				</a>

				<a href="https://globeafrique.com/icc-prosecutor-urges-sudan-to-hand-over-darfur-suspects/" rel="prev">
					<h3 class="post-title">ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects</h3>
				</a>
			</div>

			
			<div class="tie-col-xs-6 next-post">
				<a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup-390x220.jpg)" class="post-thumb">
					<div class="post-thumb-overlay-wrap">
						<div class="post-thumb-overlay">
							<span class="icon"></span>
						</div>
					</div>
				</a>

				<a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" rel="next">
					<h3 class="post-title">Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn't</h3>
				</a>
			</div>

			</div><!-- .prev-next-post-nav /-->	<div id="comments" class="comments-area">

		

		<div id="add-comment-block" class="container-wrapper">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title the-global-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/liberia-business-and-investment-forum-2021/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://globeafrique.com/wp-login.php?redirect_to=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	</div><!-- #add-comment-block /-->
	</div><!-- .comments-area -->


	</div><!-- .post-components /-->

	
</div><!-- .main-content -->


	<div id="check-also-box" class="container-wrapper check-also-right">

		<div class="widget-title the-global-title">
			<h4>Check Also</h4>

			<a href="#" id="check-also-close" class="remove">
				<span class="screen-reader-text">Close</span>
			</a>
		</div>

		<div class="widget posts-list-big-first has-first-big-post">
			<ul class="posts-list-items">

			
<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/african-medical-experts-insisting-india-should-lift-its-covid-vaccine-export-limits/" title="African medical experts insisting India should lift its COVID vaccine export limits" class="post-thumb"><h5 class="post-cat-wrap"><span class="post-cat tie-cat-3">Health</span></h5>
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="https://globeafrique.com/wp-content/uploads/2021/04/Zimbabwe-COVID-19-390x220.jpeg" class="attachment-jannah-image-large size-jannah-image-large wp-post-image" alt="" loading="lazy" srcset="https://globeafrique.com/wp-content/uploads/2021/04/Zimbabwe-COVID-19-390x220.jpeg 390w, https://globeafrique.com/wp-content/uploads/2021/04/Zimbabwe-COVID-19-300x168.jpeg 300w, https://globeafrique.com/wp-content/uploads/2021/04/Zimbabwe-COVID-19-768x431.jpeg 768w, https://globeafrique.com/wp-content/uploads/2021/04/Zimbabwe-COVID-19-610x343.jpeg 610w, https://globeafrique.com/wp-content/uploads/2021/04/Zimbabwe-COVID-19.jpeg 780w" sizes="(max-width: 390px) 100vw, 390px" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/african-medical-experts-insisting-india-should-lift-its-covid-vaccine-export-limits/" title="African medical experts insisting India should lift its COVID vaccine export limits">African medical experts insisting India should lift its COVID vaccine export limits</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>April 20, 2021</span></span>		</div>
	</div>
</li>

			</ul><!-- .related-posts-list /-->
		</div>
	</div><!-- #related-posts /-->

	
	<aside class="sidebar tie-col-md-4 tie-col-xs-12 normal-side is-sticky" aria-label="Primary Sidebar">
		<div class="theiaStickySidebar">
			<div id="tie-slider-widget-1" class="container-wrapper widget tie-slider-widget"><div class="widget-title the-global-title"><h4>Featured Articles</h4></div>
			<div class="main-slider boxed-slider boxed-five-slides-slider slider-in-widget">

				<div class="loader-overlay"><div class="spinner-circle"></div></div>
				<div class="main-slider-inner">
					<ul class="tie-slider-nav"></ul>
					<div class="container">
						<div class="tie-slick-slider">

						                      <div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup-780x405.jpg)" class="slide">
                      											<a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" title="Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t" class="all-over-thumb-link"><span class="screen-reader-text">Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t</span></a>
											<div class="thumb-overlay">
												<div class="thumb-content">
													<div class="thumb-meta"><div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span><div class="clearfix"></div></div><!-- .post-meta --></div>													<h3 class="thumb-title"><a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" title="Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t">Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t</a></h3>
												</div><!-- .thumb-content -->
											</div><!-- .thumb-overlay -->
										</div><!-- .slide /-->
										                      <div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-780x400.jpg)" class="slide">
                      											<a href="https://globeafrique.com/liberia-business-and-investment-forum-2021/" title="Liberia Business and Investment Forum 2021" class="all-over-thumb-link"><span class="screen-reader-text">Liberia Business and Investment Forum 2021</span></a>
											<div class="thumb-overlay">
												<div class="thumb-content">
													<div class="thumb-meta"><div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span><div class="clearfix"></div></div><!-- .post-meta --></div>													<h3 class="thumb-title"><a href="https://globeafrique.com/liberia-business-and-investment-forum-2021/" title="Liberia Business and Investment Forum 2021">Liberia Business and Investment Forum 2021</a></h3>
												</div><!-- .thumb-content -->
											</div><!-- .thumb-overlay -->
										</div><!-- .slide /-->
										                      <div style="background-image: url(https://globeafrique.com/wp-content/uploads/2018/08/ICC.jpeg)" class="slide">
                      											<a href="https://globeafrique.com/icc-prosecutor-urges-sudan-to-hand-over-darfur-suspects/" title="ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects" class="all-over-thumb-link"><span class="screen-reader-text">ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects</span></a>
											<div class="thumb-overlay">
												<div class="thumb-content">
													<div class="thumb-meta"><div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span><div class="clearfix"></div></div><!-- .post-meta --></div>													<h3 class="thumb-title"><a href="https://globeafrique.com/icc-prosecutor-urges-sudan-to-hand-over-darfur-suspects/" title="ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects">ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects</a></h3>
												</div><!-- .thumb-content -->
											</div><!-- .thumb-overlay -->
										</div><!-- .slide /-->
										                      <div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/Omar-Al-bashir-780x405.jpg)" class="slide">
                      											<a href="https://globeafrique.com/icc-hears-testimony-in-landmark-darfur-war-crimes-case/" title="ICC Hears Testimony in Landmark Darfur War Crimes Case" class="all-over-thumb-link"><span class="screen-reader-text">ICC Hears Testimony in Landmark Darfur War Crimes Case</span></a>
											<div class="thumb-overlay">
												<div class="thumb-content">
													<div class="thumb-meta"><div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span><div class="clearfix"></div></div><!-- .post-meta --></div>													<h3 class="thumb-title"><a href="https://globeafrique.com/icc-hears-testimony-in-landmark-darfur-war-crimes-case/" title="ICC Hears Testimony in Landmark Darfur War Crimes Case">ICC Hears Testimony in Landmark Darfur War Crimes Case</a></h3>
												</div><!-- .thumb-content -->
											</div><!-- .thumb-overlay -->
										</div><!-- .slide /-->
										                      <div style="background-image: url(https://globeafrique.com/wp-content/uploads/2021/06/African-Union-Chaos-780x405.jpg)" class="slide">
                      											<a href="https://globeafrique.com/fight-breaks-out-at-african-union-parliament/" title="Fight breaks out at African Union parliament" class="all-over-thumb-link"><span class="screen-reader-text">Fight breaks out at African Union parliament</span></a>
											<div class="thumb-overlay">
												<div class="thumb-content">
													<div class="thumb-meta"><div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 1, 2021</span></span><div class="clearfix"></div></div><!-- .post-meta --></div>													<h3 class="thumb-title"><a href="https://globeafrique.com/fight-breaks-out-at-african-union-parliament/" title="Fight breaks out at African Union parliament">Fight breaks out at African Union parliament</a></h3>
												</div><!-- .thumb-content -->
											</div><!-- .thumb-overlay -->
										</div><!-- .slide /-->
																</div><!-- .tie-slick-slider /-->
					</div><!-- .container /-->
				</div><!-- .main-slider-inner /-->
			</div><!-- #main-slider /-->
		<div class="clearfix"></div></div><!-- .widget /--><div id="posts-list-widget-2" class="container-wrapper widget posts-list"><div class="widget-title the-global-title"><h4>Popular Posts</h4></div><div class="posts-list-big-first has-first-big-post"><ul class="posts-list-items">
<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/liberia-business-and-investment-forum-2021/" title="Liberia Business and Investment Forum 2021" class="post-thumb"><h5 class="post-cat-wrap"><span class="post-cat tie-cat-7">Business</span></h5>
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="https://globeafrique.com/wp-content/uploads/2021/06/Liberia-Business-Forum-2021-390x220.jpg" class="attachment-jannah-image-large size-jannah-image-large wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/liberia-business-and-investment-forum-2021/" title="Liberia Business and Investment Forum 2021">Liberia Business and Investment Forum 2021</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/icc-prosecutor-urges-sudan-to-hand-over-darfur-suspects/" title="ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="147" src="https://globeafrique.com/wp-content/uploads/2018/08/ICC.jpeg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" srcset="https://globeafrique.com/wp-content/uploads/2018/08/ICC.jpeg 1024w, https://globeafrique.com/wp-content/uploads/2018/08/ICC-300x200.jpeg 300w, https://globeafrique.com/wp-content/uploads/2018/08/ICC-768x512.jpeg 768w, https://globeafrique.com/wp-content/uploads/2018/08/ICC-610x407.jpeg 610w" sizes="(max-width: 220px) 100vw, 220px" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/icc-prosecutor-urges-sudan-to-hand-over-darfur-suspects/" title="ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects">ICC Prosecutor Urges Sudan to Hand Over Darfur Suspects</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/fight-breaks-out-at-african-union-parliament/" title="Fight breaks out at African Union parliament" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/06/African-Union-Chaos-220x150.jpg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/fight-breaks-out-at-african-union-parliament/" title="Fight breaks out at African Union parliament">Fight breaks out at African Union parliament</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 1, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/mali-coup-are-military-takeovers-on-the-rise-in-africa/" title="Mali Coup: Are military takeovers on the rise in Africa?" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/05/Mali-army-supporters-220x150.png" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" srcset="https://globeafrique.com/wp-content/uploads/2021/05/Mali-army-supporters-220x150.png 220w, https://globeafrique.com/wp-content/uploads/2021/05/Mali-army-supporters-510x346.png 510w" sizes="(max-width: 220px) 100vw, 220px" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/mali-coup-are-military-takeovers-on-the-rise-in-africa/" title="Mali Coup: Are military takeovers on the rise in Africa?">Mali Coup: Are military takeovers on the rise in Africa?</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 31, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/voices-from-exile-vex-stands-in-firm-solidarity-with-protesting-liberian-workers-at-npa-and-frowns-on-apm-terminals-for-continuous-labor-abuse/" title="Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/05/APM-Dispute-220x150.jpg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/voices-from-exile-vex-stands-in-firm-solidarity-with-protesting-liberian-workers-at-npa-and-frowns-on-apm-terminals-for-continuous-labor-abuse/" title="Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse">Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 11, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/ed-royce-liberias-new-usd25000-per-month-lobbyist/" title="Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/05/Ed-Royce_2-220x150.jpg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/ed-royce-liberias-new-usd25000-per-month-lobbyist/" title="Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist">Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 7, 2021</span></span>		</div>
	</div>
</li>
</ul></div><div class="clearfix"></div></div><!-- .widget /--><div id="posts-list-widget-3" class="container-wrapper widget posts-list"><div class="widget-title the-global-title"><h4>Popular Opinion</h4></div><div class="posts-list-big-first has-first-big-post"><ul class="posts-list-items">
<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" title="Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t" class="post-thumb"><h5 class="post-cat-wrap"><span class="post-cat tie-cat-2100">News-Liberia</span></h5>
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup-390x220.jpg" class="attachment-jannah-image-large size-jannah-image-large wp-post-image" alt="" loading="lazy" srcset="https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup-390x220.jpg 390w, https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup-300x169.jpg 300w, https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup-768x432.jpg 768w, https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup-610x343.jpg 610w, https://globeafrique.com/wp-content/uploads/2021/06/Mali-Coup.jpg 976w" sizes="(max-width: 390px) 100vw, 390px" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/military-coup-was-everything-of-a-redemption-mali-wanted-until-it-wasnt/" title="Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t">Military Coup Was Everything Of A Redemption Mali Wanted Until It Wasn&#8217;t</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>June 2, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/ecowas-suspends-mali-after-the-second-coup-in-9-months/" title="ECOWAS suspends Mali after the second coup in 9 months" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/05/Ecowas-suspends-Mali-220x150.jpeg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/ecowas-suspends-mali-after-the-second-coup-in-9-months/" title="ECOWAS suspends Mali after the second coup in 9 months">ECOWAS suspends Mali after the second coup in 9 months</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 31, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/voices-from-exile-vex-stands-in-firm-solidarity-with-protesting-liberian-workers-at-npa-and-frowns-on-apm-terminals-for-continuous-labor-abuse/" title="Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/05/APM-Dispute-220x150.jpg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/voices-from-exile-vex-stands-in-firm-solidarity-with-protesting-liberian-workers-at-npa-and-frowns-on-apm-terminals-for-continuous-labor-abuse/" title="Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse">Voices from Exile (VEx) stands in firm solidarity with protesting Liberian workers at NPA and frowns on APM Terminals for continuous Labor Abuse</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 11, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/ed-royce-liberias-new-usd25000-per-month-lobbyist/" title="Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/05/Ed-Royce_2-220x150.jpg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/ed-royce-liberias-new-usd25000-per-month-lobbyist/" title="Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist">Ed Royce: Liberia&#8217;s New USD$25,000 Per Month Lobbyist</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 7, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/episode-1-george-weah-ousmane-bamba-the-europeans-russians-and-how-the-2017-elections-were-rigged/" title="Episode 1: George Weah, Ousmane Bamba, the Europeans, Russians, and How the 2017 Elections were Rigged" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/05/Weah-220x150.jpg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/episode-1-george-weah-ousmane-bamba-the-europeans-russians-and-how-the-2017-elections-were-rigged/" title="Episode 1: George Weah, Ousmane Bamba, the Europeans, Russians, and How the 2017 Elections were Rigged">Episode 1: George Weah, Ousmane Bamba, the Europeans, Russians, and How the 2017 Elections were Rigged</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 5, 2021</span></span>		</div>
	</div>
</li>

<li class="widget-post-list tie-standard">

			<div class="post-widget-thumbnail">

			
			<a href="https://globeafrique.com/opinion-why-chauvins-conviction-is-not-a-victory-for-justice/" title="Opinion: Why Chauvin&#8217;s Conviction is not a Victory for Justice" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="220" height="150" src="https://globeafrique.com/wp-content/uploads/2021/04/Chauvin-220x150.jpeg" class="attachment-jannah-image-small size-jannah-image-small tie-small-image wp-post-image" alt="" loading="lazy" /></a>		</div><!-- post-alignleft /-->
	
	<div class="post-widget-body ">
		<h3 class="post-title"><a href="https://globeafrique.com/opinion-why-chauvins-conviction-is-not-a-victory-for-justice/" title="Opinion: Why Chauvin&#8217;s Conviction is not a Victory for Justice">Opinion: Why Chauvin&#8217;s Conviction is not a Victory for Justice</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>April 23, 2021</span></span>		</div>
	</div>
</li>
</ul></div><div class="clearfix"></div></div><!-- .widget /-->		</div><!-- .theiaStickySidebar /-->
	</aside><!-- .sidebar /-->
	
				</div><!-- .main-content-row /-->
			</div><!-- #content /-->
		
<footer id="footer" class="site-footer dark-skin dark-widgetized-area">

	
			<div id="footer-widgets-container">
				<div class="container">
					

		<div class="footer-widget-area footer-boxed-widget-area">
			<div class="tie-row">

									<div class="fullwidth-area tie-col-sm-12">
						<div id="tag_cloud-1" class="container-wrapper widget widget_tag_cloud"><div class="widget-title the-global-title"><h4>Looking For More?</h4></div><div class="tagcloud"><a href="https://globeafrique.com/category/blog/" class="tag-cloud-link tag-link-26 tag-link-position-1" style="font-size: 18.808823529412pt;" aria-label="Blog (253 items)">Blog</a>
<a href="https://globeafrique.com/category/business/" class="tag-cloud-link tag-link-7 tag-link-position-2" style="font-size: 16.544117647059pt;" aria-label="Business (91 items)">Business</a>
<a href="https://globeafrique.com/category/campaign/" class="tag-cloud-link tag-link-27 tag-link-position-3" style="font-size: 15.875pt;" aria-label="Campaign (67 items)">Campaign</a>
<a href="https://globeafrique.com/category/comedy/" class="tag-cloud-link tag-link-1016 tag-link-position-4" style="font-size: 9.5441176470588pt;" aria-label="Comedy (3 items)">Comedy</a>
<a href="https://globeafrique.com/category/corruption/" class="tag-cloud-link tag-link-1034 tag-link-position-5" style="font-size: 12.786764705882pt;" aria-label="Corruption (16 items)">Corruption</a>
<a href="https://globeafrique.com/category/corruption-liberia/" class="tag-cloud-link tag-link-2109 tag-link-position-6" style="font-size: 11.345588235294pt;" aria-label="Corruption-Liberia (8 items)">Corruption-Liberia</a>
<a href="https://globeafrique.com/category/justice/" class="tag-cloud-link tag-link-1342 tag-link-position-7" style="font-size: 13.455882352941pt;" aria-label="Crime and Justice (22 items)">Crime and Justice</a>
<a href="https://globeafrique.com/category/economy/" class="tag-cloud-link tag-link-2106 tag-link-position-8" style="font-size: 10.830882352941pt;" aria-label="Economy-Liberia (6 items)">Economy-Liberia</a>
<a href="https://globeafrique.com/category/election/" class="tag-cloud-link tag-link-29 tag-link-position-9" style="font-size: 16.132352941176pt;" aria-label="Election (74 items)">Election</a>
<a href="https://globeafrique.com/category/energy-environment/" class="tag-cloud-link tag-link-30 tag-link-position-10" style="font-size: 12.941176470588pt;" aria-label="Energy &amp; Environment (17 items)">Energy &amp; Environment</a>
<a href="https://globeafrique.com/category/entertainment/" class="tag-cloud-link tag-link-16 tag-link-position-11" style="font-size: 16.904411764706pt;" aria-label="Entertainment (106 items)">Entertainment</a>
<a href="https://globeafrique.com/category/events/" class="tag-cloud-link tag-link-9 tag-link-position-12" style="font-size: 10.470588235294pt;" aria-label="Events (5 items)">Events</a>
<a href="https://globeafrique.com/category/executive_branch/" class="tag-cloud-link tag-link-2108 tag-link-position-13" style="font-size: 10.058823529412pt;" aria-label="Executive-branch-Liberia (4 items)">Executive-branch-Liberia</a>
<a href="https://globeafrique.com/category/fashion/" class="tag-cloud-link tag-link-17 tag-link-position-14" style="font-size: 12.014705882353pt;" aria-label="Fashion (11 items)">Fashion</a>
<a href="https://globeafrique.com/category/food/" class="tag-cloud-link tag-link-31 tag-link-position-15" style="font-size: 13.455882352941pt;" aria-label="Food (22 items)">Food</a>
<a href="https://globeafrique.com/category/tie-world/tie-foods/" class="tag-cloud-link tag-link-1820 tag-link-position-16" style="font-size: 10.830882352941pt;" aria-label="Foods (6 items)">Foods</a>
<a href="https://globeafrique.com/category/globe_afrique_liberia/" class="tag-cloud-link tag-link-2110 tag-link-position-17" style="font-size: 14.691176470588pt;" aria-label="Globe Afrique Liberia (39 items)">Globe Afrique Liberia</a>
<a href="https://globeafrique.com/category/governance/" class="tag-cloud-link tag-link-32 tag-link-position-18" style="font-size: 17.573529411765pt;" aria-label="Governance (143 items)">Governance</a>
<a href="https://globeafrique.com/category/health/" class="tag-cloud-link tag-link-3 tag-link-position-19" style="font-size: 16.595588235294pt;" aria-label="Health (93 items)">Health</a>
<a href="https://globeafrique.com/category/human-rights/" class="tag-cloud-link tag-link-33 tag-link-position-20" style="font-size: 15.257352941176pt;" aria-label="Human Rights (50 items)">Human Rights</a>
<a href="https://globeafrique.com/category/international_development/" class="tag-cloud-link tag-link-11 tag-link-position-21" style="font-size: 17.161764705882pt;" aria-label="International Development (120 items)">International Development</a>
<a href="https://globeafrique.com/category/in-the-news/" class="tag-cloud-link tag-link-986 tag-link-position-22" style="font-size: 17.882352941176pt;" aria-label="In the News (165 items)">In the News</a>
<a href="https://globeafrique.com/category/lawmakers/" class="tag-cloud-link tag-link-2104 tag-link-position-23" style="font-size: 8pt;" aria-label="Lawmakers-Liberia (1 item)">Lawmakers-Liberia</a>
<a href="https://globeafrique.com/category/letters/" class="tag-cloud-link tag-link-328 tag-link-position-24" style="font-size: 11.345588235294pt;" aria-label="Letters to the Editor (8 items)">Letters to the Editor</a>
<a href="https://globeafrique.com/category/liberia/" class="tag-cloud-link tag-link-2099 tag-link-position-25" style="font-size: 10.830882352941pt;" aria-label="Liberia (6 items)">Liberia</a>
<a href="https://globeafrique.com/category/lifestyle/" class="tag-cloud-link tag-link-34 tag-link-position-26" style="font-size: 14.897058823529pt;" aria-label="Lifestyle (43 items)">Lifestyle</a>
<a href="https://globeafrique.com/category/news/" class="tag-cloud-link tag-link-2 tag-link-position-27" style="font-size: 22pt;" aria-label="News (1,058 items)">News</a>
<a href="https://globeafrique.com/category/news-liberia/" class="tag-cloud-link tag-link-2100 tag-link-position-28" style="font-size: 15.566176470588pt;" aria-label="News-Liberia (58 items)">News-Liberia</a>
<a href="https://globeafrique.com/category/opinion/" class="tag-cloud-link tag-link-5 tag-link-position-29" style="font-size: 19.838235294118pt;" aria-label="Opinion (401 items)">Opinion</a>
<a href="https://globeafrique.com/category/opinion-liberia/" class="tag-cloud-link tag-link-2103 tag-link-position-30" style="font-size: 15.875pt;" aria-label="Opinion-Liberia (66 items)">Opinion-Liberia</a>
<a href="https://globeafrique.com/category/opinion-poll/" class="tag-cloud-link tag-link-35 tag-link-position-31" style="font-size: 8.9264705882353pt;" aria-label="Opinion poll (2 items)">Opinion poll</a>
<a href="https://globeafrique.com/category/policy/" class="tag-cloud-link tag-link-36 tag-link-position-32" style="font-size: 13.558823529412pt;" aria-label="Policy (23 items)">Policy</a>
<a href="https://globeafrique.com/category/politics/" class="tag-cloud-link tag-link-2101 tag-link-position-33" style="font-size: 14.073529411765pt;" aria-label="Politics-Liberia (29 items)">Politics-Liberia</a>
<a href="https://globeafrique.com/category/protest/" class="tag-cloud-link tag-link-2107 tag-link-position-34" style="font-size: 10.470588235294pt;" aria-label="Protest-Liberia (5 items)">Protest-Liberia</a>
<a href="https://globeafrique.com/category/religion/" class="tag-cloud-link tag-link-1 tag-link-position-35" style="font-size: 13.044117647059pt;" aria-label="Religion (18 items)">Religion</a>
<a href="https://globeafrique.com/category/sports/" class="tag-cloud-link tag-link-18 tag-link-position-36" style="font-size: 16.492647058824pt;" aria-label="Sports (88 items)">Sports</a>
<a href="https://globeafrique.com/category/sports-liberia/" class="tag-cloud-link tag-link-2102 tag-link-position-37" style="font-size: 11.088235294118pt;" aria-label="Sports-Liberia (7 items)">Sports-Liberia</a>
<a href="https://globeafrique.com/category/technology/" class="tag-cloud-link tag-link-10 tag-link-position-38" style="font-size: 15.308823529412pt;" aria-label="Technology (51 items)">Technology</a>
<a href="https://globeafrique.com/category/news/the-latest/" class="tag-cloud-link tag-link-1826 tag-link-position-39" style="font-size: 12.014705882353pt;" aria-label="The Latest (11 items)">The Latest</a>
<a href="https://globeafrique.com/category/travel/" class="tag-cloud-link tag-link-37 tag-link-position-40" style="font-size: 10.058823529412pt;" aria-label="Travel (4 items)">Travel</a>
<a href="https://globeafrique.com/category/tv-film/" class="tag-cloud-link tag-link-38 tag-link-position-41" style="font-size: 12.169117647059pt;" aria-label="TV and Film (12 items)">TV and Film</a>
<a href="https://globeafrique.com/category/video/" class="tag-cloud-link tag-link-4 tag-link-position-42" style="font-size: 15.205882352941pt;" aria-label="Video (49 items)">Video</a>
<a href="https://globeafrique.com/category/in-the-news/voice-of-the-diaspora/" class="tag-cloud-link tag-link-1434 tag-link-position-43" style="font-size: 8.9264705882353pt;" aria-label="Voice of the Diaspora (2 items)">Voice of the Diaspora</a>
<a href="https://globeafrique.com/category/weddings/" class="tag-cloud-link tag-link-41 tag-link-position-44" style="font-size: 10.470588235294pt;" aria-label="Weddings (5 items)">Weddings</a>
<a href="https://globeafrique.com/category/tie-world/" class="tag-cloud-link tag-link-1808 tag-link-position-45" style="font-size: 13.25pt;" aria-label="World (20 items)">World</a></div>
<div class="clearfix"></div></div><!-- .widget /-->					</div><!-- .tie-col /-->
				
									<div class="">
											</div><!-- .tie-col /-->
				
									<div class="">
											</div><!-- .tie-col /-->
				
									<div class="">
											</div><!-- .tie-col /-->
				
			</div><!-- .tie-row /-->
		</div><!-- .footer-widget-area /-->

		
				</div><!-- .container /-->
			</div><!-- #Footer-widgets-container /-->
			
			<div id="site-info" class="site-info">
				<div class="container">
					<div class="tie-row">
						<div class="tie-col-md-12">

							<div class="copyright-text copyright-text-first">&copy; Copyright 2021, All Rights Reserved &nbsp;|&nbsp; <span style="color:red;" class="fa fa-heart"></span> <a href="https://www.ikenotech.com/" target="_blank">Globe Afrique by IKENOTech</a></div><div class="copyright-text copyright-text-second"><span id="siteseal"><script async type="text/javascript" src="https://seal.godaddy.com/getSeal?sealID=j8jhVb3ItLiiMakhVZiuw8YSAkIOAwbsfwQctFH0B2V0xop2GOugz65RO0gY"></script></span></div><div class="footer-menu"><ul id="menu-main-menu-2" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-17934"><a href="https://globeafrique.com/">LIBERIA</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14492"><a href="https://globeafrique.com/category/blog/">WORLD</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14493"><a href="https://globeafrique.com/category/governance/">POLITICS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14491"><a href="https://globeafrique.com/category/opinion/">OPINION</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-14497 tie-current-menu"><a href="https://globeafrique.com/category/business/">BUSINESS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14500"><a href="https://globeafrique.com/category/justice/">JUSTICE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14495"><a href="https://globeafrique.com/category/entertainment/">ENTERTAINMENT</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17905"><a href="#">LIVING</a></li>
</ul></div><ul class="social-icons"><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-facebook"></span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-twitter"></span></a></li><li class="social-icons-item"><a class="social-link  youtube-social-icon" title="YouTube" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-youtube"></span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-instagram"></span></a></li></ul> 

						</div><!-- .tie-col /-->
					</div><!-- .tie-row /-->
				</div><!-- .container /-->
			</div><!-- #site-info /-->
			
</footer><!-- #footer /-->


		<div class="post-footer post-footer-on-mobile">
			<div class="share-links  icons-only">
				<a href="https://www.facebook.com/sharer.php?u=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="facebook-share-btn"><span class="fa fa-facebook"></span> <span class="screen-reader-text">Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Liberia+Business+and+Investment+Forum+2021&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="twitter-share-btn"><span class="fa fa-twitter"></span> <span class="screen-reader-text">Twitter</span></a><a href="https://plusone.google.com/_/+1/confirm?hl=en&#038;url=https://globeafrique.com/liberia-business-and-investment-forum-2021/&#038;name=Liberia+Business+and+Investment+Forum+2021" rel="external noopener" target="_blank" class="google-share-btn"><span class="fa fa-google"></span> <span class="screen-reader-text">Google+</span></a><a href="whatsapp://send?text=Liberia+Business+and+Investment+Forum+2021 - https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="whatsapp-share-btn"><span class="fa fa-whatsapp"></span> <span class="screen-reader-text">WhatsApp</span></a><a href="tg://msg?text=Liberia+Business+and+Investment+Forum+2021 - https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="telegram-share-btn"><span class="fa fa-paper-plane"></span> <span class="screen-reader-text">Telegram</span></a><a href="viber://forward?text=Liberia+Business+and+Investment+Forum+2021 - https://globeafrique.com/liberia-business-and-investment-forum-2021/" rel="external noopener" target="_blank" class="viber-share-btn"><span class="fa fa-volume-control-phone"></span> <span class="screen-reader-text">Viber</span></a>			</div><!-- .share-links /-->
		</div><!-- .post-footer-on-top /-->

		<div class="mobile-share-buttons-spacer"></div>
		<a id="go-to-top" class="go-to-top-button" href="#go-to-tie-body">
			<span class="fa fa-angle-up"></span>
			<span class="screen-reader-text">Back to top button</span>
		</a>
		<div class="clear"></div>
	
		</div><!-- #tie-wrapper /-->

		

	<aside class="side-aside normal-side tie-aside-effect dark-skin dark-widgetized-area is-fullwidth" aria-label="Secondary Sidebar">
		<div data-height="100%" class="side-aside-wrapper has-custom-scroll">

			<a href="#" class="close-side-aside remove big-btn light-btn">
				<span class="screen-reader-text">Close</span>
			</a><!-- .close-side-aside /-->

			<div id="mobile-container">

				
				<div id="mobile-menu" class="hide-menu-icons">

					
				</div><!-- #mobile-menu /-->

				<div class="mobile-social-search">
											<div id="mobile-social-icons" class="social-icons-widget solid-social-icons">
							<ul><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-facebook"></span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-twitter"></span></a></li><li class="social-icons-item"><a class="social-link  youtube-social-icon" title="YouTube" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-youtube"></span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="#"><span class="fa fa-instagram"></span></a></li></ul> 
						</div><!-- #mobile-social-icons /-->
												<div id="mobile-search">
							<form role="search" method="get" class="search-form" action="https://globeafrique.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</div><!-- #mobile-search /-->
										</div><!-- #mobile-social-search /-->

			</div><!-- #mobile-container /-->


			
				<div id="slide-sidebar-widgets">
					<div id="posts-list-widget-4" class="container-wrapper widget posts-list"><div class="widget-title the-global-title"><h4>Most Commented</h4></div><div class="timeline-widget"><ul class="posts-list-items">					<li>
						<a href="https://globeafrique.com/tanzania-president-climbs-down-on-corrupt-and-renegade-officials/">
							<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>October 27, 2016</span></span>							<h3>Tanzania President Clamps Down on Corrupt and Renegade Officials</h3>
						</a>
					</li>
										<li>
						<a href="https://globeafrique.com/deferral-in-somalia-presidential-election-raises-fears-of-manipulation-and-control/">
							<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>October 27, 2016</span></span>							<h3>Deferral in Somalia Presidential Election Raises Fears of Manipulation and Control</h3>
						</a>
					</li>
										<li>
						<a href="https://globeafrique.com/zimbabwe-liberia-face-fragile-economic-situation/">
							<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>October 27, 2016</span></span>							<h3>Zimbabwe, Liberia Face Fragile Economic Situation</h3>
						</a>
					</li>
										<li>
						<a href="https://globeafrique.com/it-was-in-the-family-mugabe-uses-sons-as-delegates-for-his-countrys-visit-at-un-assembly/">
							<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>October 27, 2016</span></span>							<h3>It was in the Family, Mugabe uses sons as delegates for his country’s visit at UN Assembly</h3>
						</a>
					</li>
										<li>
						<a href="https://globeafrique.com/rwanda-advances-health-care-delivery-using-medical-drone/">
							<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>October 27, 2016</span></span>							<h3>Rwanda advances health care delivery using medical drone</h3>
						</a>
					</li>
										<li>
						<a href="https://globeafrique.com/south-africas-war-crime-court-withdrawer-a-setback-for-global-justice/">
							<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>October 27, 2016</span></span>							<h3>South Africa’s war crime court withdrawal a setback for global justice</h3>
						</a>
					</li>
					</ul></div><div class="clearfix"></div></div><!-- .widget /--><div id="comments_avatar-widget-1" class="container-wrapper widget recent-comments-widget"><div class="widget-title the-global-title"><h4>Recent Comments</h4></div><ul></ul><div class="clearfix"></div></div><!-- .widget /-->				</div>
			
		</div><!-- .side-aside-wrapper /-->
	</aside><!-- .side-aside /-->

	
	</div><!-- #tie-container /-->
</div><!-- .background-overlay /-->

<div id="glt-translate-trigger"><span class="notranslate">Translate &raquo;</span></div><div id="glt-toolbar"></div><div id="flags" style="display:none" class="size18"><ul id="sortable" class="ui-sortable"><li id="English"><a href="#" title="English" class="nturl notranslate en flag English"></a></li></ul></div><div id='glt-footer'><div id="google_language_translator" class="default-language-en"></div></div><script>function GoogleLanguageTranslatorInit() { new google.translate.TranslateElement({pageLanguage: 'en', includedLanguages:'en', autoDisplay: false}, 'google_language_translator');}</script><div class="et_bloom_popup et_bloom_optin et_bloom_resize et_bloom_optin_1 et_bloom_auto_close">
							<div class="et_bloom_form_container et_bloom_popup_container et_bloom_form_bottom with_edge carrot_edge et_bloom_with_border et_bloom_border_inset et_bloom_border_position_top et_bloom_rounded et_bloom_form_text_dark et_bloom_animation_no_animation">
								
			<div class="et_bloom_form_container_wrapper clearfix">
				<div class="et_bloom_header_outer">
					<div class="et_bloom_form_header et_bloom_header_text_light">
						<img src="https://globeafrique.com/wp-content/plugins/bloom/images/premade-image-14.png" alt="Subscribe To Globe Afrique" class="et_bloom_hide_mobile et_bloom_image_no_animation et_bloom_image">
						<div class="et_bloom_form_text">
						<h2>Subscribe To Globe Afrique</h2><p>Join our mailing list to receive the latest news and updates from our team.</p>
					</div>
						
					</div>
				</div>
				<div class="et_bloom_form_content et_bloom_2_fields et_bloom_bottom_stacked">
					
					
					<form method="post" class="clearfix">
						<div class="et_bloom_fields">
							<p class="et_bloom_popup_input et_bloom_subscribe_name">
								<input placeholder="Name" maxlength="50">
							</p>
							<p class="et_bloom_popup_input et_bloom_subscribe_email">
								<input placeholder="Email">
							</p>
							
							<button data-optin_id="optin_1" data-service="mailchimp" data-list_id="4d170f3435" data-page_id="19350" data-account="GlobeAfrique_Media" data-ip_address="false" class="et_bloom_submit_subscription">
								<span class="et_bloom_subscribe_loader"></span>
								<span class="et_bloom_button_text et_bloom_button_text_color_light">SUBSCRIBE!</span>
							</button>
						</div>
					</form>
					<div class="et_bloom_success_container">
						<span class="et_bloom_success_checkmark"></span>
					</div>
					<h2 class="et_bloom_success_message">You have Successfully Subscribed!</h2>
					<div class="et_bloom_form_footer">info@globeafrique.com</div>
				</div>
			</div>
			<span class="et_bloom_close_button"></span>
							</div>
						</div><div class="et_social_pin_images_outer">
					<div class="et_social_pinterest_window">
						<div class="et_social_modal_header"><h3>Pin It on Pinterest</h3><span class="et_social_close"></span></div>
						<div class="et_social_pin_images" data-permalink="https://globeafrique.com/liberia-business-and-investment-forum-2021/" data-title="Liberia Business and Investment Forum 2021" data-post_id="19350"></div>
					</div>
				</div><div class="et_social_sidebar_networks et_social_visible_sidebar et_social_slideright et_social_animated et_social_circle et_social_sidebar_flip et_social_mobile_on">
					
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;t=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_twitter">
									<a href="http://twitter.com/share?text=Liberia%20Business%20and%20Investment%20Forum%202021&#038;url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_pinterest">
									<a href="#" class="et_social_share_pinterest" rel="nofollow" data-social_name="pinterest" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_gmail">
									<a href="https://mail.google.com/mail/u/0/?view=cm&#038;fs=1&#038;su=Liberia%20Business%20and%20Investment%20Forum%202021&#038;body=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;ui=2&#038;tf=1" class="et_social_share" rel="nofollow" data-social_name="gmail" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_gmail"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_printfriendly">
									<a href="http://www.printfriendly.com/print?url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;title=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="printfriendly" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_yahoomail">
									<a href="http://compose.mail.yahoo.com/?body=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F" class="et_social_share" rel="nofollow" data-social_name="yahoomail" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_yahoomail"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_linkedin">
									<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;title=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="linkedin" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_tumblr">
									<a href="https://www.tumblr.com/share?v=3&#038;u=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;t=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="tumblr" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_tumblr"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li></ul>
					<span class="et_social_hide_sidebar et_social_icon"></span>
				</div><div class="et_social_mobile_button"></div>
					<div class="et_social_mobile et_social_fadein">
						<div class="et_social_heading">Share This</div>
						<span class="et_social_close"></span>
						<div class="et_social_networks et_social_simple et_social_rounded et_social_left">
							<ul class="et_social_icons_container"><li class="et_social_facebook">
									<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;t=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_facebook"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">https://www.facebook.com/search/top/?q=globeafrique</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_twitter">
									<a href="http://twitter.com/share?text=Liberia%20Business%20and%20Investment%20Forum%202021&#038;url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_twitter"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">https://twitter.com/AfriqueGlobe</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_pinterest">
									<a href="#" class="et_social_share_pinterest" rel="nofollow" data-social_name="pinterest" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Pinterest</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_gmail">
									<a href="https://mail.google.com/mail/u/0/?view=cm&#038;fs=1&#038;su=Liberia%20Business%20and%20Investment%20Forum%202021&#038;body=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;ui=2&#038;tf=1" class="et_social_share" rel="nofollow" data-social_name="gmail" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_gmail"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Gmail</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_printfriendly">
									<a href="http://www.printfriendly.com/print?url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;title=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="printfriendly" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Print Friendly</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_yahoomail">
									<a href="http://compose.mail.yahoo.com/?body=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F" class="et_social_share" rel="nofollow" data-social_name="yahoomail" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_yahoomail"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Yahoo Mail</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_linkedin">
									<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;title=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="linkedin" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">LinkedIn</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_tumblr">
									<a href="https://www.tumblr.com/share?v=3&#038;u=https%3A%2F%2Fglobeafrique.com%2Fliberia-business-and-investment-forum-2021%2F&#038;t=Liberia%20Business%20and%20Investment%20Forum%202021" class="et_social_share" rel="nofollow" data-social_name="tumblr" data-post_id="19350" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_tumblr"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Tumblr</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li></ul>
						</div>
					</div>
					<div class="et_social_mobile_overlay"></div><div id="reading-position-indicator"></div><div id="fb-root"></div>	<div id="tie-popup-login" class="tie-popup">
		<a href="#" class="tie-btn-close remove big-btn light-btn">
			<span class="screen-reader-text">Close</span>
		</a>
		<div class="tie-popup-container">
			<div class="container-wrapper">
				<div class="widget login-widget">

					
					<div class="widget-title the-global-title">
						<h4>Log In <span class="widget-title-icon fa "></span>
						</h4>
					</div>

					<div class="widget-container">
						
			<div class="login-form">

				<form name="registerform" action="https://globeafrique.com/wp-login.php" method="post">
					<input type="text" name="log" title="Username" placeholder="Username">
					<div class="pass-container">
						<input type="password" name="pwd" title="Password" placeholder="Password">
						<a class="forget-text" href="https://globeafrique.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Fglobeafrique.com">Forget?</a>
					</div>

					<input type="hidden" name="redirect_to" value="/liberia-business-and-investment-forum-2021/"/>
					<label for="rememberme" class="rememberme">
						<input id="rememberme" name="rememberme" type="checkbox" checked="checked" value="forever" /> Remember me					</label>

					
					
					<button type="submit" class="button fullwidth login-submit">Log In</button>

									</form>

				
			</div>
								</div><!-- .widget-container  /-->
				</div><!-- .login-widget  /-->
			</div><!-- .container-wrapper  /-->
		</div><!-- .tie-popup-container /-->
	</div><!-- .tie-popup /-->
	
<!-- BEGIN recaptcha, injected by plugin wp-recaptcha-integration  -->
<script type="text/javascript">
		var recaptcha_widgets={};
		function wp_recaptchaLoadCallback(){
			try {
				grecaptcha;
			} catch(err){
				return;
			}
			var e = document.querySelectorAll ? document.querySelectorAll('.g-recaptcha:not(.wpcf7-form-control)') : document.getElementsByClassName('g-recaptcha'),
				form_submits;

			for (var i=0;i<e.length;i++) {
				(function(el){
					var wid;
					// check if captcha element is unrendered
					if ( ! el.childNodes.length) {
						wid = grecaptcha.render(el,{
							'sitekey':'6Le8XYkUAAAAAI65z0f2ErvNg7WSa_JjdHIeUnGh',
							'theme':el.getAttribute('data-theme') || 'light'
						});
						el.setAttribute('data-widget-id',wid);
					} else {
						wid = el.getAttribute('data-widget-id');
						grecaptcha.reset(wid);
					}
				})(e[i]);
			}
		}

		// if jquery present re-render jquery/ajax loaded captcha elements
		if ( typeof jQuery !== 'undefined' )
			jQuery(document).ajaxComplete( function(evt,xhr,set){
				if( xhr.responseText && xhr.responseText.indexOf('6Le8XYkUAAAAAI65z0f2ErvNg7WSa_JjdHIeUnGh') !== -1)
					wp_recaptchaLoadCallback();
			} );

		</script><script src="https://www.google.com/recaptcha/api.js?onload=wp_recaptchaLoadCallback&#038;render=explicit" async defer></script>
<!-- END recaptcha -->

<!-- font handler -->
    <link rel='stylesheet' id='et_bloom-css-css'  href='https://globeafrique.com/wp-content/plugins/bloom/css/style.css' type='text/css' media='all' />
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/google-language-translator/js/scripts.js' id='scripts-js'></script>
<script   type='text/javascript' src='//translate.google.com/translate_a/element.js?cb=GoogleLanguageTranslatorInit' id='scripts-google-js'></script>
<script type='text/javascript' id='forms-for-campaign-monitor-ajax-script-public-js-extra'>
/* <![CDATA[ */
var ajax_request = {"ajax_url":"https:\/\/globeafrique.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/forms-for-campaign-monitor/forms/views/public/js/app.js' id='forms-for-campaign-monitor-ajax-script-public-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/monarch/js/idle-timer.min.js' id='et_monarch-idle-js'></script>
<script type='text/javascript' id='et_monarch-custom-js-js-extra'>
/* <![CDATA[ */
var monarchSettings = {"ajaxurl":"https:\/\/globeafrique.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/","stats_nonce":"6644b60516","share_counts":"18274456ea","follow_counts":"a726b4c661","total_counts":"31551d33a6","media_single":"2e68af2b78","media_total":"551126b8eb","generate_all_window_nonce":"bce03b22f5","no_img_message":"No images available for sharing on this page"};
/* ]]> */
</script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/monarch/js/custom.js' id='et_monarch-custom-js-js'></script>
<script type='text/javascript' id='divi-builder-custom-script-js-extra'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"https:\/\/globeafrique.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/globeafrique.com\/wp-content\/themes\/jannah\/images","builder_images_uri":"https:\/\/globeafrique.com\/wp-content\/plugins\/divi-builder\/includes\/builder\/images","et_frontend_nonce":"143536bdbb","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"98ede20bdb","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"19350","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""}; var et_builder_utils_params = {"condition":{"diviTheme":false,"extraTheme":false},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
var et_pb_motion_elements = {"desktop":[],"tablet":[],"phone":[]};
var et_pb_sticky_elements = [];
/* ]]> */
</script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/divi-builder/js/divi-builder.min.js' id='divi-builder-custom-script-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/divi-builder/core/admin/js/common.js' id='et-core-common-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/themes/jannah/assets/js/scripts.js' id='tie-scripts-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/themes/jannah/assets/js/sliders.js' id='tie-js-sliders-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/bloom/js/jquery.uniform.min.js' id='et_bloom-uniform-js-js'></script>
<script type='text/javascript' id='et_bloom-custom-js-js-extra'>
/* <![CDATA[ */
var bloomSettings = {"ajaxurl":"https:\/\/globeafrique.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/globeafrique.com\/liberia-business-and-investment-forum-2021\/","stats_nonce":"809f737a82","subscribe_nonce":"a142dc4ae4","is_user_logged_in":"not_logged"};
/* ]]> */
</script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/bloom/js/custom.js' id='et_bloom-custom-js-js'></script>
<script   type='text/javascript' src='https://globeafrique.com/wp-content/plugins/bloom/js/idle-timer.min.js' id='et_bloom-idle-timer-js-js'></script>
</body>
</html>
